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Getting Started with UML2 
Summary  
 
This article describes how to get started with the UML2 plug-ins for Eclipse. In particular, it gives an overview of how to create models (and their 
contents) both programmatically and by using the sample UML editor. 

By Kenn Hussey, IBM  
July 18, 2006     (Updated: July 11, 2008 for Eclipse 3.4; James Bruck) 

Prerequisites 
To start using UML2 (and to follow along with the example in this article), you must have Eclipse 3.4, EMF 2.4, and UML2 2.2 installed.   

You can either download the zips individually and expand them out or follow the steps below:   

1)  Download and run Eclipse 3.4 

2)  Select the Help > Software Updates … menu 

3)  Select the Available Software  tab and expand the Ganymede\Model and Model Development  tree item. 

 

4)  Select UML2 End-User Features  and UML2 Extender SDK .  The version should indicate 2.2.0 (or later). 

5)  Click Install… . 

At this stage, UML2 2.2 and all dependencies should be installed. 

  

Introduction 
This article will walk you through the basics of creating models using UML2. Using a simple model (the ExtendedPO2 model, shamelessly “borrowed” from the 
EMF “bible” [1]) as an example, we’ll look at what’s involved in creating some of the more common elements that make up a model. For each type of element, 
we’ll first explain the creation process using the sample UML editor and then explore how to accomplish the same thing using Java code. The ExtendedPO2 
model is shown below. 
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Getting Started 
Before getting started, you’ll need to create a simple project in your workspace. This project will serve as the container for the model that we’ll create using the 
UML editor. To create a simple project for this article, follow these steps: 

1) Select the Window > Open Perspective > Other…  menu item. 

2) Select the Resource  perspective and press the OK button. 

3) Select the File > New > Project...  menu item. 

4) Select the Project  wizard from the General  category and press the Next >  button. 

5) Enter a project name (i.e. “Getting Started with UML2”) and press the Finish  button. 

At this point your workspace should look something like this: 
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OK, that should be enough to get us going with the UML editor. Now, to follow along with the programmatic approach to creating models, we’ll assume that 
you’ve created a class (named, say, “GettingStartedWithUML2”) in which you can write some code to construct our sample model. The code snippets we’ll 
show assume you’ve defined the following utility methods to give the user information on the program’s status: 

  public static boolean DEBUG = true; 
  
     protected static void out(String output) { 
  
            if (DEBUG) { 

                 System.out.println(output); 
            } 
     } 
  
     protected static void err(String error) { 

         System.err.println(error); 
     } 

A static debug flag  can be used to enable or disable verbose information printed to the system’s output stream . Errors will always be printed to the 

system’s error stream . 

All righty then! In each of the following subsections, we’ll look at how to create a different kind of UML element, starting with models. 

Creating Models 

At the root of a typical UML model is a model element. It contains a (hierarchical) set of elements that together describe the physical system being modeled. To 
create a model using the UML editor, follow these steps: 

1) Select a project (i.e. Getting Started with UML2 ) in the Project Explorer  view and select the File > New > Other...  menu item. 

2) Select the UML Model  wizard from the Example EMF Model Creation Wizards  category and press the Next >  button. 

3) Enter a file name (i.e. “ExtendedPO2.uml”) and press the Next >  button. 

4) Select Model  for the model object and press the Finish  button. 

5) Select the Window > Show View > Properties  menu item. 

6) Select the <Model>  element in the UML editor. 

7) Enter a value (i.e. “epo2”) for the Name property in the Properties  view. 

At this point your workspace should look something like this: 
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Let’s look at how to perform the same task using Java code. The code snippet below shows a method that programmatically creates and returns a model with a 
specified name. 

     protected static Model createModel(String name ) { 
         Model model = UMLFactory.eINSTANCE.createM odel(); 
         model.setName(name); 

  
         out("Model '" + model.getQualifiedName() +  "' created."); 

  
         return model; 

     } 

First, we ask the UML factory singleton  to create a model, and we set its name . Then, we output information  to the user to let them know that the 

model has been successfully created. Finally, we return  the model. You’ll notice most, if not all, of the code snippets in this article will follow this pattern – 

create the element (and set some properties on it), inform the user, and return it. 

 All named elements (a model is a type of named element) have a “simple” name and a qualified name. The qualified name is the “simple” name 
prefixed with the “simple” names of all of the named element’s containing namespaces. Note that the qualified name of a named element is only defined if all of 
its containing namespaces have non-empty “simple” names. 

OK, let’s see this method in action. For example, we could create a model named ‘epo2’ as follows: 

            Model epo2Model = createModel("epo2"); 

Creating Packages 

A package is a namespace for its members (packageable elements), and may contain other packages. A package can import either individual members of other 
packages, or all of the members of other packages. To create a package using the UML editor, follow these steps: 

1) Select a package (e.g. <Package> foo ) in the UML editor. 

2) Right-click and select the New Child > Packaged Element Package  option from the context menu. 

3) Enter a value (e.g. “bar”) for the Name property in the Properties  view. 

We don’t actually need to create a package because our sample model doesn’t contain any… except of course for the root package (i.e. the model). That’s right 
– a model is a type of package. 

Let’s look at how to perform the same task using Java code. The code snippet below shows a method that programmatically creates and returns a package with 
a specified name in a specified nesting package. 

     protected static org.eclipse.uml2.uml.Package createPackage( 
                    org.eclipse.uml2.uml.Package ne stingPackage, String name) { 

         org.eclipse.uml2.uml.Package package_ = ne stingPackage 
                    .createNestedPackage(name); 
  
            out("Package '" + package_.getQualified Name() + "' created."); 
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            return package_; 
     } 

Here, instead of asking the factory to create the package for us, we’re making use of one of the factory methods  in the UML2 API. 

 In UML2, a factory method exists for every feature that can contain other elements (i.e. every containment feature). In addition, more convenient 
factory methods exist for commonly created types (like packages). In this case, the package has a feature (packagedElement ) that can contain packageable 
elements, so we could obtain the Ecore class of the type of (packageable) element we want to create (i.e. Package ) from the UML Ecore package singleton, 
and pass it to the createPackagedElement(String, EClass)  factory method. Instead, we use the more convenient createNestedPackage(String)  
factory method which implicitly creates a package and accepts the desired package name as an argument. Behind the scenes, the package will create a nested 
package, set its name, and add the package to its list of packaged elements. 

OK, let’s see this method in action. For example, we could create a package named ‘bar’ in nesting package ‘foo’ as follows: 

            org.eclipse.uml2.uml.Package barPackage  = createPackage(fooPackage, "bar"); 

Creating Primitive Types 

A primitive type defines a predefined data type, without any relevant substructure. Primitive types used in UML™ itself include Boolean , Integer , 
UnlimitedNatural , and String . To create a primitive type using the UML editor, follow these steps: 

1) Select a package (i.e. <Model> epo2 ) in the UML editor. 

2) Right-click and select the New Child > Packaged Element > Primitive Type  option from the context menu. 

3) Enter a value (i.e. “int”) for the Name property in the Properties  view. 

 Create the remaining primitive types from the ExtendedPO2 model using the UML editor. 

At this point your workspace should look something like this: 

 

Let’s look at how to perform the same task using Java code. The code snippet below shows a method that programmatically creates and returns a primitive type 
with a specified name in a specified package. 

     protected static PrimitiveType createPrimitive Type( 
                    org.eclipse.uml2.uml.Package pa ckage_, String name) { 

         PrimitiveType primitiveType = (PrimitiveTy pe) package_ 
                    .createOwnedPrimitiveType(name) ; 
  
            out("Primitive type '" + primitiveType. getQualifiedName() 
                    + "' created."); 
  
            return primitiveType; 
     } 

Here we call the createOwnedPrimitiveType(String)  convenience factory method  to ask the package to create a primitive type with the specified 
name as one of its packaged elements. 
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OK, let’s see this method in action. For example, we could create a primitive type named ‘int’ in model ‘epo2’ as follows: 

            PrimitiveType intPrimitiveType = create PrimitiveType(epo2Model, "int"); 

 Write code to programmatically create the remaining primitive types from the ExtendedPO2 model. 

Creating Enumerations 

An enumeration is a kind of data type whose instances may be any of a number of user-defined enumeration literals. To create an enumeration using the UML 
editor, follow these steps: 

1) Select a package (i.e. <Model> epo2 ) in the UML editor. 

2) Right-click and select the New Child > Packaged Element > Enumeration  option from the context menu. 

3) Enter a value (i.e. “OrderStatus”) for the Name property in the Properties  view. 

At this point your workspace should look something like this: 

 

Let’s look at how to perform the same task using Java code. The code snippet below shows a method that programmatically creates and returns an 
enumeration with a specified name in a specified package. 

     protected static Enumeration createEnumeration ( 
                    org.eclipse.uml2.uml.Package pa ckage_, String name) { 

         Enumeration enumeration = (Enumeration) pa ckage_ 
                    .createOwnedEnumeraton(name); 
  
            out("Enumeration '" + enumeration.getQu alifiedName() + "' created."); 
  
            return enumeration; 
     } 

Here we call the createOwnedEnumeration(String)  convenience factory method  to ask the package to create a primitive type with the specified 
name as one of its packaged elements. 

OK, let’s see this method in action. For example, we could create an enumeration named ‘OrderStatus’ in model ‘epo2’ as follows: 

            Enumeration orderStatusEnumeration = cr eateEnumeration(epo2Model, 
                    "OrderStatus"); 

Creating Enumeration Literals 

An enumeration literal is a user-defined data value for an enumeration. To create an enumeration literal using the UML editor, follow these steps: 

1) Select an enumeration (i.e. <Enumeration> OrderStatus ) in the UML editor. 

2) Right-click and select the New Child > Owned Literal > Enumeration Literal  option from the context menu. 
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3) Enter a value (i.e. “Pending”) for the Name property in the Properties  view. 

 Create the remaining enumeration literals from the ExtendedPO2 model using the UML editor. 

At this point your workspace should look something like this: 

 

Let’s look at how to perform the same task using Java code. The code snippet below shows a method that programmatically creates and returns an 
enumeration literal with a specified name in a specified enumeration. 

     protected static EnumerationLiteral createEnum erationLiteral( 
                    Enumeration enumeration, String  name) { 

         EnumerationLiteral enumerationLiteral = en umeration 
                    .createOwnedLiteral(name); 
  
            out("Enumeration literal '" + enumerati onLiteral.getQualifiedName() 
                    + "' created."); 
  
            return enumerationLiteral; 
     } 

Here we call a createOwnedLiteral(String)  convenience factory method  to ask the enumeration to create an enumeration literal with the specified 
name as one of its owned literals. 

OK, let’s see this method in action. For example, we could create an enumeration literal named ‘Pending’ in enumeration ‘OrderStatus’ as follows: 

            createEnumerationLiteral(orderStatusEnu meration, "Pending"); 

 Write code to programmatically create the remaining enumeration literals from the ExtendedPO2 model. 

Creating Classes 

A class is a kind of classifier whose features are attributes (some of which may represent the navigable ends of associations) and operations. To create a class 
using the UML editor, follow these steps: 

1) Select a package (i.e. <Model> epo2 ) in the UML editor. 

2) Right-click and select the New Child > Packaged Element > Class  option from the context menu. 

3) Enter a value (i.e. “Supplier”) for the Name property in the Properties  view. 

 Create the remaining classes from the ExtendedPO2 model using the UML editor. 

At this point your workspace should look something like this: 
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Let’s look at how to perform the same task using Java code. The code snippet below shows a method that programmatically creates and returns a(n) (abstract) 
class with a specified name in a specified package. 

     protected static org.eclipse.uml2.uml.Class cr eateClass( 
                    org.eclipse.uml2.uml.Package pa ckage_, String name, boolean isAbstract) { 

         org.eclipse.uml2.uml.Class class_ = packag e_.createOwnedClass(name, 
                    isAbstract); 
  
            out("Class '" + class_.getQualifiedName () + "' created."); 
  
            return class_; 
     } 

Here we call the createOwnedClass(String, boolean)  convenience factory method  to ask the package to create a class with the specified name as 
one of its packaged elements, and set the isAbstract  attribute of the class based on the specified boolean  argument. 

 You may have noticed that we have been fully qualifying references to the Package  and Class  interfaces. This is recommended so that these 
types are not confused with java.lang.Class  and java.lang.Package , which are imported implicitly in Java. 

OK, let’s see this method in action. For example, we could create a non-abstract class named ‘Supplier’ in model ‘epo2’ as follows: 

            org.eclipse.uml2.uml.Class supplierClas s = createClass(epo2Model, 
                    "Supplier", false); 

 Write code to programmatically create the remaining classes from the ExtendedPO2 model. 

Creating Generalizations 

A generalization is a taxonomic relationship between a specific classifier and a more general classifier whereby each instance of the specific classifier is also an 
indirect instance of, and inherits the features of, the general classifier. To create a generalization using the UML editor, follow these steps: 

1) Select a classifier (i.e. <Class> USAddress ) in the UML editor. 

2) Right-click and select the New Child > Generalization > Generalization  option from the context menu. 

3) Select a value (i.e. epo2::Address ) for the General  property in the Properties  view. 

 Create the remaining generalizations from the ExtendedPO2 model using the UML editor. 

At this point your workspace should look something like this: 
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Let’s look at how to perform the same task using Java code. The code snippet below shows a method that programmatically creates and returns a 
generalization between specified specific and general classifiers. 

     protected static Generalization createGenerali zation( 
                    Classifier specificClassifier, Classifier generalClassifier) { 
            Generalization generalization = specifi cClassifier 

                 .createGeneralization(generalClass ifier); 
  
            out("Generalization " + specificClassif ier.getQualifiedName() + " ->> " 
                    + generalClassifier.getQualifie dName() + " created."); 
  
            return generalization; 
     } 

Here we call a convenience factory method on the specific classifier that creates a generalization  as one of its children and sets the general classifier to the 
specified argument. 

OK, let’s see this method in action. For example, we could create a generalization between specific class ‘USAddress’ and general class ‘Address’ as follows: 

            createGeneralization(usAddressClass, ad dressClass); 

 Write code to programmatically create the remaining generalizations from the ExtendedPO2 model. 

Creating Attributes 

When a property is owned by a classifier it represents an attribute; in this case is relates an instance of the classifier to a value or set of values of the type of the 
attribute. 

 The types of Classifier  that can own attributes in UML2 include Artifact , DataType , Interface , Signal , and StructuredClassifier  
(and their subtypes). 

To create an attribute using the UML editor, follow these steps: 

1) Select a classifier (i.e. <Class> Address ) in the UML editor. 

2) Right-click and select the New Child > Owned Attribute > Property  option from the context menu. 

3) Enter a value (i.e. "name”) for the Name property in the Properties  view. 

4) Select a value (i.e. epo2::String ) for the Type  property in the Properties  view. 

5) Enter a value (i.e. 0) for the Lower  property in the Properties  view. 
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 Lower and upper values for multiplicity elements (like properties) are represented as value specifications (first-class objects) in UML™ 2.x. The 
default value for lower and upper bounds is 1, unless a child value specification exists, in which case its value is used. Specifying a value for the lower or upper 
property will create a child value specification if none exists, or update its value if one does. Note that, to be treated as a bound, the lower value must be an 
integer and the upper value must be an unlimited natural.  

 Create the remaining attributes from the ExtendedPO2 model using the UML editor. 

At this point your workspace should look something like this: 

 

Let’s look at how to perform the same task using Java code. The code snippet below shows a method that programmatically creates and returns an attribute 
with a specified upper bound, lower bound, type, and name in a specified class. 

     protected static Property createAttribute(org. eclipse.uml2.uml.Class class_, 
                    String name, Type type, int low erBound, int upperBound) { 

         Property attribute = class_.createOwnedAtt ribute(name, type, 
                    lowerBound, upperBound); 
  
            StringBuffer sb = new StringBuffer(); 
  
            sb.append("Attribute '"); 
  
            sb.append(attribute.getQualifiedName()) ; 
  
            sb.append("' : "); 
  
            sb.append(type.getQualifiedName()); 
  
            sb.append(" ["); 
            sb.append(lowerBound); 
            sb.append(".."); 
            sb.append(LiteralUnlimitedNatural.UNLIM ITED == upperBound 
                    ? "*" 
                    : String.valueOf(upperBound)); 
            sb.append("]"); 
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            sb.append(" created."); 
  
            out(sb.toString()); 
  
            return attribute; 
     } 

Here we call a createOwnedAttribute(String, Type, int, int)  convenience factory method  to ask the class to create a property as one of its 
owned attributes, set the type of the attribute to the specified type, and set the lower and upper bounds of the attribute (the factory method indirectly creates a 
literal integer and literal unlimited natural, respectively, and sets their values to the specified integer values). 

 The LiteralUnlimitedNatural.UNLIMITED  constant represents the unlimited value for upper bounds (-1), as it does in EMF; when setting this 
value in the Properties  view, an asterisk (‘*’) can alternatively be specified. 

OK, let’s see this method in action. For example, we could create an attribute with multiplicity 0..1 of type ‘String’ named ‘name’ in class ‘Supplier’ as follows: 

            createAttribute(supplierClass, "name", stringPrimitiveType, 0, 1); 

 Write code to programmatically create the remaining attributes from the ExtendedPO2 model. 

Creating Associations 

An association specifies a semantic relationship that can occur between two or more typed instances; its ends are represented by properties, each of which is 
connected to the type of the end. When a property is owned by an association it represents a non-navigable end of the association, in which case the type of 
the property is the type of the association end. 

 The notion of association end navigability was separated from that of ownership in the UML™ 2.0 specification, so a property that is owned by an 
association isn’t necessarily non-navigable as of UML2 2.0. 

To create an association using the UML editor, follow these steps: 

1) Select a package (i.e. <Model> epo2 ) in the UML editor. 

2) Right-click and select the New Child > Packaged Element > Association  option from the context menu. 

3) Enter a value (e.g. “A_orders_supplier”) for the Name property in the Properties  view. 

4) Select the association (i.e. <Association> A_orders_supplier ) in the UML editor. 

5) Right-click and select the New Child > Owned End > Property  option from the context menu. 

6) Select a value (i.e. epo2::Supplier ) for the Type  property in the Properties  view. 

7) Select a class (i.e. <Class> Supplier ) in the UML editor. 

8) Right-click and select the New Child > Owned Attribute > Property  option from the context menu. 

9) Select a value (i.e. Composite ) for the Aggregation  property in the Properties  view. 

10) Select a value (i.e. epo2::A_orders_supplier ) for the Association  property in the Properties  view. 

11) Enter a value (i.e. "orders") for the Name property in the Properties  view. 

12) Select a value (i.e. epo2::PurchaseOrder ) for the Type  property in the Properties  view. 

13) Enter a value (i.e. 0) for the Lower  property in the Properties  view. 

14) Enter a value (i.e. *) for the Upper  property in the Properties  view. 

 Create the remaining associations from the ExtendedPO2 model using the UML editor. 

At this point your workspace should look something like this: 

Page 11 of 14Getting Started with UML2

08-08-2008http://www.eclipse.org/modeling/mdt/uml2/docs/articles/Getting_Started_with_UML...



 

Let’s look at how to perform the same task using Java code. The code snippet below shows a method that programmatically creates and returns an association 
between two specified types, with ends that have the specified upper bounds, lower bounds, role names, aggregation kinds, and navigabilities. 

     protected static Association createAssociation (Type type1, 
                    boolean end1IsNavigable, Aggreg ationKind end1Aggregation, 
                    String end1Name, int end1LowerB ound, int end1UpperBound, 
                    Type type2, boolean end2IsNavig able, 
                    AggregationKind end2Aggregation , String end2Name, 
                    int end2LowerBound, int end2Upp erBound) { 
  

         Association association = type1.createAsso ciation(end1IsNavigable, 
                    end1Aggregation, end1Name, end1 LowerBound, end1UpperBound, type2, 
                    end2IsNavigable, end2Aggregatio n, end2Name, end2LowerBound, 
                    end2UpperBound); 
  
            StringBuffer sb = new StringBuffer(); 
  
            sb.append("Association "); 
  
            if (null == end1Name || 0 == end1Name.l ength()) { 
                    sb.append('{'); 
                    sb.append(type1.getQualifiedNam e()); 
                    sb.append('}'); 
            } else { 
                    sb.append("'"); 
                    sb.append(type1.getQualifiedNam e()); 
                    sb.append(NamedElement.SEPARATO R); 
                    sb.append(end1Name); 
                    sb.append("'"); 
            } 
  
            sb.append(" ["); 
            sb.append(end1LowerBound); 
            sb.append(".."); 
            sb.append(LiteralUnlimitedNatural.UNLIM ITED == end1UpperBound 
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                    ? "*" 
                    : String.valueOf(end1UpperBound )); 
            sb.append("] "); 
  
            sb.append(end2IsNavigable 
                    ? '<' 
                    : '-'); 
            sb.append('-'); 
            sb.append(end1IsNavigable 
                    ? '>' 
                    : '-'); 
            sb.append(' '); 
  
            if (null == end2Name || 0 == end2Name.l ength()) { 
                    sb.append('{'); 
                    sb.append(type2.getQualifiedNam e()); 
                    sb.append('}'); 
            } else { 
                    sb.append("'"); 
                    sb.append(type2.getQualifiedNam e()); 
                    sb.append(NamedElement.SEPARATO R); 
                    sb.append(end2Name); 
                    sb.append("'"); 
            } 
  
            sb.append(" ["); 
            sb.append(end2LowerBound); 
            sb.append(".."); 
            sb.append(LiteralUnlimitedNatural.UNLIM ITED == end2UpperBound 
                    ? "*" 
                    : String.valueOf(end2UpperBound )); 
            sb.append("]"); 
  
            sb.append(" created."); 
  
            out(sb.toString()); 
  
            return association; 
     } 

Here we call a convenience factory method on the first end type that creates an association (and its ends) between it and another type  as one of its siblings 
(i.e. as a child of its package namespace) and with the specified upper bounds, lower bounds, role names, aggregation kinds, and navigabilities. The owners of 
the association ends (properties) are based on the specified navigabilities – navigable ends are owned by the end type if allowed, otherwise they are owned by 
the association; non-navigable ends are owned by the association. 

 The NamedElement.SEPARATOR constant represents the standard separator (:: ) used in qualified names. 

OK, let’s see this method in action. For example, we could create a unidirectional composition (composite association) between classes ‘Supplier’ and 
‘PurchaseOrder’ in model ‘epo2’ as follows: 

            createAssociation(supplierClass, true, 
                    AggregationKind.COMPOSITE_LITER AL, "orders", 0, 
                    LiteralUnlimitedNatural.UNLIMIT ED, purchaseOrderClass, 
                    false, AggregationKind.NONE_LIT ERAL, "", 1, 1); 

 Write code to programmatically create the remaining associations from the ExtendedPO2 model. 

Saving Models 

Now that we’ve spent all this time creating a model, we’d better save our work. When we created our model using the UML model wizard, a UML resource was 
created for us, so now all that needs to be done is to serialize the contents of our model as XMI to our file on disk (i.e. ExtendedPO2.uml ). To save a model 
using the UML editor, follow these steps: 

1) Select the File > Save  menu item. 

It’s that simple. Programmatically, we have a bit more work to do because so far, we’ve been creating our model in a vacuum, i.e. without a containing resource. 
The code snippet below shows a method that saves a specified package to a resource with a specified URI. 

     protected static void save(org.eclipse.uml2.um l.Package package_, URI uri) { 
         Resource resource = new ResourceSetImpl(). createResource(uri); 
         resource.getContents().add(package_); 

  
            try { 

                 resource.save(null); 
                    out("Done."); 
            } catch (IOException ioe) { 

                 err(ioe.getMessage()); 
            } 
     } 

Here we create a resource set  and a resource with the specified URI, add the package to the resource’s contents , and ask the resource to save itself 
 using the default options. If an exception occurs, we notify the user  via our handy utility method. 

OK, let’s see this method in action. For example, we could save the ‘epo2’ model to a resource with URI ‘ExtendedPO2.uml’ (relative to a URI passed in as an 
argument) as follows: 

            save(epo2Model, URI.createURI(args[0]). appendSegment("ExtendedPO2") 
                    .appendFileExtension(UMLResourc e.FILE_EXTENSION)); 
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 The UMLResource.FILE_EXTENSION  constant represents the file extension for UML resources (.uml ). Note that the UMLResource  interface 
contains a number of constants that you will find useful when working with UML resources. 

Conclusion 
Congratulations! If you’ve made it this far, you’ve successfully created a simple model programmatically and/or using the UML editor. There’s a whole lot more 
that could be said, but the purpose of this article was just to get you started. Stay tuned for more articles on how to develop tools with UML2. 

For more information on UML2, visit the home page or join the newsgroup. 
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Source Code 
To run the example or view the source code for this article, unzip uml2.articles_200607181325.zip into your Eclipse home directory and import the 
com.ibm.uml2.articles  plug-in into your workspace as a binary project with linked content (File > Import… > External Plug-ins and Fragments ). You 
can run the GettingStartedWithUML2  class as a Java application with a file URI (e.g. “file:/C:/Getting Started with UML2”) as a program argument. 

Java and all Java-based trademarks and logos are trademarks or registered trademarks of Sun Microsystems, Inc. in the United States, other countries, or both. 
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